WebApp and Mobile App are experiencing login issues for some users and regions.
Incident Report for Celsius Status Page
Resolved
This incident has been resolved.
Posted Jun 11, 2022 - 20:38 UTC
Investigating
We are currently investigating this issue.
Posted Jun 11, 2022 - 20:22 UTC